Big Data Module トップ > サポート > FAQ

Big Data Module FAQ インストール・トラブルシューティング編

インストールと起動について

  1. ライセンスファイルを実行すると「ライセンス登録に失敗しました : Error ??」と出ます。
  2. ライセンスファイルをダブルクリックしても、何もおきず、Big Data Module を起動すると「ライセンスが有効でない」と出ます
  3. 起動時に「ライセンス管理」というウインドウが出て VAP が起動しません。
  4. Visual Analytics Platformは起動したのですが、Big Data Moduleのアイコンが見つかりません。

操作について

  1. Big Data Moduleのアイコンを実行しようとしたのですが、ダイアログが起動しません。
  2. アイコンの実行結果がファイルパスになってしまいます。
  3. 過去にインポートしたデータを、再度インポートせずに使いたいです。
  4. Big Data Moduleのアイコンの結果を、VMStudioなどの他の製品と接続したいです。
  5. 分析アイコンの「リスト」と「マトリックス」の違いが分かりません。
  6. バージョン1.1以前で作成したプロジェクトのBD予測アイコン及び BD検証アイコンをバージョン1.3で利用するには

回答 一覧

  1. ライセンスファイルを実行すると「ライセンス登録に失敗しました : Error ??」と出ます。

    ライセンス登録エラー

    以下をご確認ください。

    vmk ファイルを取得した後、もう一度 Big Data Module を再インストールして、ライセンスファイルを実行していませんか?
    この場合、インストール時に入力したユーザー名、シリアル番号が同じであれば、再発行の必要はありません(入力を要求されなかった場合も不要です)。もし違う情報を入力した場合は、ライセンスの再発行が必要ですので、bdmodule_info.bin を再度送付してください。

    ライセンスを発行する際に送付していただいた bdmodule_info.bin が存在するマシンと違うマシンで vmk ファイルを実行していませんか?
    Big Data Module は、実行するマシンごとにライセンス発行が必要です。実行マシンを増やしたい場合や、変更したい場合はお問い合わせください。

    一度 Big Data Module をインストールした後、Windows をバージョンアップして Big Data Module を再インストールしていませんか?
    Big Data Module は実行環境固有の情報からライセンスを生成しています。この場合も Error がでますので、bigdata-info@msi.co.jp にお問い合わせください。

    Big Data Module をインストールした後に、Windowsのアクティベーション(ライセンス登録)を行っていませんか。
    Big Data Module は実行環境固有の情報からライセンスを生成しています。Windowsのアクティベーション(ライセンス登録)は、実行環境固有の情報を変更してしまいます。一旦アンインストールの上、再度インストールを行い、ライセンス申請を行ってください。


  2. ライセンスファイルをダブルクリックしても、何もおきず、Big Data Module を起動すると「ライセンスが有効でない」と出ます。

    次の手順でライセンス登録プログラムを起動してください。

    1. スタートボタンを押し、 「すべてのプログラム」-「MSI Solutions」-「ツール」-「License Installer」を選択してください。
    2. 起動するとライセンス登録ウインドウが開きます。

    3. ライセンス登録ダイアログ

      参照ボタンを押してライセンスファイル(*.vmk)を指定して OK ボタンを押すと、ライセンスが登録されます。


  3. 起動時に「ライセンス管理」というウインドウが出て VAP が起動しません。

    ライセンス管理

    このウインドウは VAP を各ユーザーが初めて起動したときに現れます。次のようにしてユーザーを追加してください。

    1. ライセンス管理ウインドウを右クリックして、メニューから「ユーザー追加」を選択します。
    2. 作業フォルダを作成する場所を聞いてきますので、適当な場所を入力し(通常はそのままで結構です)OKボタンを押します。

    これで VAP の起動が可能となります。


  4. VAP は起動したのですが、Big Data Module のアイコンが見つかりません。

    Big Data Module を使用するためには、製品選択を行う必要があります。

    製品選択は VAP のメニューバーの「製品」-「製品の選択」から行います。Big Data Module にチェックを付けて「OK」ボタンを押してください。


    製品の選択


  5. Big Data Moduleのアイコンを実行しようとしたのですが、ダイアログが起動しません。

    Big Data Module の多くのアイコンは、入力ファイルの形式が従来の VAP のアイコンと異なり、ファイルパスの一覧を入力として受け付けます。通常の VAP のテーブルを入力ファイルに指定した場合、正しく動作しません。

    マニュアルのp10から、Big Data Module のチュートリアルがございます。初めて Big Data Module をお使いの方は、ぜひご一読くださいませ。

    マニュアルは VAP のメニューバーの「ヘルプ」-「Big Data Module」-「マニュアル&チュートリアル」 から開くことができます。


  6. アイコンの実行結果がファイルパスになってしまいます。

    Big Data Module では、大規模データに対して効率的に処理を行うために、分割されたデータを束ねて1つのデータとして扱います。

    このため、一部のアイコンでは結果が1つのvdtファイルにならず、結果が分割されたvdtファイルとなります。

    このようなファイルの中身を確認する場合や、他のソフトウェアのアイコンに接続する場合には、BDサンプリングアイコンなどを使用してデータをまとめてください。


  7. 過去にインポートしたデータを、再度インポートせずに使いたいです。

    使用するvdtファイルのパスの一覧を作成すれば、Big Data Module のアイコンの入力として既にインポート済みのvdtファイルを使用することが可能です。

    例えば、スクリプトで次のようなコマンドを実行することで、特定のフォルダ内のvdtファイルパスの一覧を取得することが可能です。

    result = dirp("C:¥vdtFolder","*.vdt");

    vdtファイルは「BDインポート」アイコンで作成されたものに限らず、従来のVAPVMStudioの機能でインポートされたものでもかまいません。


  8. Big Data Module のアイコンの結果を、VMStudio などの他の製品と接続したいです。

    結果がファイルパス一覧の形式で結果が出力されるアイコンに対しては、「BDサンプリング」もしくは「BDスカッシング」アイコンを使用することで、データを圧縮しながら通常の VAP のアイコンと同じ形式に変換することができ、この結果を通常の VAP アイコンの入力テーブルとして使用することができます。

    特に、「BDサンプリング」アイコンで、サンプルサイズ100%とした場合には、圧縮せずにデータ形式の変換を行うことができます。

    ただし、通常の VAP のテーブルには、およそ22億行の行数制限があるため、データサイズが大きい場合には、圧縮を行う必要がありますのでご注意ください。


  9. 分析アイコンの「リスト」と「マトリックス」の違いが分かりません。

    「BD線形回帰(マトリックス)」、「BD線形回帰(リスト)」のように、(マトリックス)、(リスト)がついた分析アイコンがあります。

    これらは、入力テーブルとして受け付けるデータの形式が違うだけで、分析の内容は全く同じです。御使用のデータの形式に合わせて、対応するアイコンをご使用ください。リスト形式とマトリックス形式の違いについては、マニュアルのP57を参照してください。

    マニュアルは VAP のメニューバーの「ヘルプ」-「Big Data Module」-「マニュアル&チュートリアル」から開くことができます。


  10. バージョン1.1以前で作成したプロジェクトのBD予測アイコン及び BD検証アイコンをバージョン1.3で利用するには

    バージョン1.3 では BD 予測アイコン、BD 検証アイコンの仕様が変更されたため、バージョン1.1 以前でプロジェクトボードに配置した これらのアイコンは使用できません。
    すでに該当アイコンをご使用の場合は、お手数ですが以下の手順で再度設定をお願いいたします。

    1. プロジェクトボード(右側の画面)のBD 予測アイコン、BD 検証アイコンを削除する
    2. オブジェクトブラウザ(左側のエクスプローラ風画面)の中からBD 予測アイコン、BD 検証アイコンをプロジェクトボードへ配置して、矢印を接続し直す
    3. 配置し直したアイコンに接続されている学習アイコン(BD 線形回帰、BD ロジスティック回帰、BDSVM のいずれか)を実行し直す。
    4. 予測アイコン、BD検証アイコンを実行して、入出力マッチング定義を次のように設定
      • model:学習アイコンのresult
      • table: 予測、検証対象データ